Cruise Control Problem - Nissan-Navara.net
Technical assistance 3.0 V6 Dci Got a problem with your 3.0 V6 Navara? Please request help here, hopefully one of us can help.

 2Likes
  • 1 Post By lookskyward1
  • 1 Post By Marksman56
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 07-12-16, 01:20 AM Thread Starter
Into 2nd gear now!
 
Join Date: Mar 2016
Location: Norfolk UK
Posts: 42
Cruise Control Problem

Have seen quite a few threads on here regarding Cruise Control not engaging but they all seem to be on manual box Navaras. The CC won't engage my auto Outlaw, the light on the dash comes on put pressing set does nothing. It's still under warranty so it's not a huge problem but I don't really want the hassle of taking it to a Nissan dealership if it's something quite trivial or I can at least give them some idea as to the problem.
Any thoughts on a solution will be greatly appreciated!
Marksman56 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-12-16, 09:48 AM
Administrator
 
lookskyward1's Avatar
 
Join Date: Jan 2009
Location: South Lanarkshire UK
Posts: 15,203
Garage
Send a message via Yahoo to lookskyward1
It is possibly the clock spring in the steering hub.

However why guess and spend money when your dealer will investigate and fix it for free. If you start messing about with it and still don't fix it you're giving the dealer an excuse to refuse to honour the warranty.

2007 Euro4, D40 Outlaw in black.

Get your forum stickers here:
http://www.nissan-navara.net/39-foru...-stickers.html


lookskyward1 is online now  
post #3 of 8 (permalink) Old 07-12-16, 10:05 AM Thread Starter
Into 2nd gear now!
 
Join Date: Mar 2016
Location: Norfolk UK
Posts: 42
Quote:
Originally Posted by lookskyward1 View Post
It is possibly the clock spring in the steering hub.

However why guess and spend money when your dealer will investigate and fix it for free. If you start messing about with it and still don't fix it you're giving the dealer an excuse to refuse to honour the warranty.
Yes Lookskyward, what you say makes sense, but just wondered if there was an easily accessible switch or something that needed tweaking or a squirt of WD40. When you say steering hub and clock spring you've lost me anyway!
I should have mentioned the speed limiter works perfectly. Should also mention that I've noticed on a couple of occasions the brake light switch has stuck leaving brake lights on until pedal depressed again
Many Thanks
Marksman56 is offline  
 
post #4 of 8 (permalink) Old 07-12-16, 10:14 AM
Administrator
 
lookskyward1's Avatar
 
Join Date: Jan 2009
Location: South Lanarkshire UK
Posts: 15,203
Garage
Send a message via Yahoo to lookskyward1
If the brake light switch is sticking, that will cause the CC not to engage. I don't suppose it will do any harm giving it a scoosh of WD40 although it's not guaranteed to work and a strip down or replacement will be needed.

You are best to get the dealer to fix it though and they'll just replace the part.
freemansteve likes this.

2007 Euro4, D40 Outlaw in black.

Get your forum stickers here:
http://www.nissan-navara.net/39-foru...-stickers.html


lookskyward1 is online now  
post #5 of 8 (permalink) Old 23-12-16, 12:54 PM Thread Starter
Into 2nd gear now!
 
Join Date: Mar 2016
Location: Norfolk UK
Posts: 42
Quote:
Originally Posted by lookskyward1 View Post
If the brake light switch is sticking, that will cause the CC not to engage. I don't suppose it will do any harm giving it a scoosh of WD40 although it's not guaranteed to work and a strip down or replacement will be needed.

You are best to get the dealer to fix it though and they'll just replace the part.
Problem diagnosed to brake pedal switches. New switches ordered. Pity they do not hold them in stock then it could have all been sorted in one trip saving me another couple of hours messing about!
Marksman56 is offline  
post #6 of 8 (permalink) Old 09-01-17, 01:42 PM Thread Starter
Into 2nd gear now!
 
Join Date: Mar 2016
Location: Norfolk UK
Posts: 42
New switches fitted, cruise control working perfectly......only surprise is I now have to depress the brake pedal to get out of park where as before I just held the button on the lever and it would move.
lookskyward1 likes this.
Marksman56 is offline  
post #7 of 8 (permalink) Old 09-01-17, 05:45 PM
Fully run in and going strong!
 
landmannnn's Avatar
 
Join Date: May 2007
Location: Coventry and the Limousin
Posts: 5,165
Can't have one without the other!
landmannnn is online now  
post #8 of 8 (permalink) Old 11-01-17, 11:12 AM Thread Starter
Into 2nd gear now!
 
Join Date: Mar 2016
Location: Norfolk UK
Posts: 42
Not complaining , just came as a bit of a surprise first time I went to use it following the repair......made me scratch my head for 30 secs!!!!!
Marksman56 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan-Navara.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Image Verification
Please enter the six letters or digits that appear in the image opposite.

Registration Image


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome