It is currently Tue Jul 29, 2014 11:40 am
Bill Car Engineering


All times are UTC [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: keeps blowing 100 amp fusable link!
PostPosted: Wed Dec 08, 2010 9:02 pm 
Offline
Im new
Im new

Joined: Wed Dec 08, 2010 2:32 pm
Posts: 3
Hello i have a 2.2 ( dont laugh yes it destroyed the big end bolts ) d22 that keeps blowing the 100amp fuse in the main engine fuse box.

i have disconnected the alt and abs pump and still its blowing. using my volt meter i can tell it still has a short.

have a workshop manual but the wiring diagrams arent great

was just wondering if anybody has had this problem? had a good search around and cant seem to find out much about it.


Top
 Profile  
 
Nissan-Navara.net
Advertisement
 Post subject: Re: keeps blowing 100 amp fusable link!
PostPosted: Wed Dec 08, 2010 9:08 pm 
Offline
I'm now in 4th gear with power to spare!
I'm now in 4th gear with power to spare!

Joined: Mon Jan 05, 2009 12:07 pm
Posts: 195
possible starter


Top
 Profile  
 
 Post subject: Re: keeps blowing 100 amp fusable link!
PostPosted: Wed Dec 08, 2010 10:32 pm 
Offline
Im new
Im new

Joined: Wed Dec 08, 2010 2:32 pm
Posts: 3
seems to be a different circuit as the starter is still turning the engine over with the fuse blown. Starters generally use several 100 amps and are not normally fused.

thanks for the reply though looks like i am going to have to start stripping the looms down, oh what joy!


Top
 Profile  
 
 Post subject: Re: keeps blowing 100 amp fusable link!
PostPosted: Wed Dec 08, 2010 11:38 pm 
Offline
Global Moderator
Global Moderator
User avatar

Joined: Wed Jan 07, 2009 8:50 pm
Posts: 5970
Location: Isle of Mull
Give the main ignition switch a check. I would have thought that's the common area for the main ignition related harness to meet. With a little luck you will find a worn through wire/short.

Good luck

_________________
If it isn't broke, bodge it anyway


Top
 Profile  
 
 Post subject: Re: keeps blowing 100 amp fusable link!
PostPosted: Thu Dec 09, 2010 12:31 am 
Offline
On the motorway!
On the motorway!
User avatar

Joined: Thu Jan 25, 2007 8:37 pm
Posts: 1444
Location: Farnborough Hampshire
I had a small fire in mine, it had rubbed through the loom, and shorted on a sharp metal support behind the dash, although it didn't blow any fuses.
Search for the thread 'and now the ba***rd has caught fire'.
Might help you?
Chris

_________________
Very first upgraded D22 - 8 years and 60K miles and still going strong!


Top
 Profile  
 
 Post subject: Re: keeps blowing 100 amp fusable link!
PostPosted: Thu Dec 09, 2010 8:58 am 
Offline
Im new
Im new

Joined: Wed Dec 08, 2010 2:32 pm
Posts: 3
will do ! thanks everybody you have been really helpful, i will let you know how i get on today


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Nissan-navara.net is neither connected to nor affiliated with Nissan Motors.