Nissan-Navara.net banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Forum Notices - Please read before posting
    Hello all, I'm posting here because I hope one of you guys will be able to offer some advice / guidence. I've revently stripped the half shafts out of the rear axle to replace the oil seals (fairly common problem and not too challenging a fix (or so I thought......)) Unfortunately, whilst...
  2. Questions & Answers (D40 Diesels)
    Hi All, I'm just doing some work under my 2009 D40 and trying to get a few jobs done. Whilst in the process of removing the old exhaust to fit a new Stainless one from Cybox the two bolts holding the front exhaust rubber mounting bracket sheared off!...... I used an impact driver when I should...
  3. Introduce yourself
    Been on the site a while but not posted anything really, just getting a lot of info from everyone. I've got a D40 2009 Aventura and have just started to try and get it all sorted underneath. A new stainless exhaust from Cybox and need to fix the rear diff seal where the prop shaft goes in, I've...
  4. Questions & Answers (D40 Diesels)
    Hey all. I’m new to this forum and am looking for a bit of help with my 2008 Spanish D40. It has this issue where if I’m in a hill, it really struggles to get the revs up (especially bad when it’s cold). If I let the clutch out, I can put the pedal to the floor and it just won’t rev up at all...
  5. Questions & Answers (D40 Diesels)
    About a week ago my D40 2011 Navara went into limp mode out of the blue. Myself and a mechanic apprentice mate troubleshooted things such as: Fuel Filter Boost Solenoid MAF Clean ECU reset SCV (Had been replaced by previous owner experiencing loss of power and black smoke) - This was not...
1-5 of 5 Results
Top