Nissan-Navara.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1
hi all, air bag light started to flash while driving. done the reset which worked. but it starts to flash after about 30 seconds of driving every time. any ideas. cheers.

Sent from my SM-A520F using Tapatalk
 

·
Registered
Joined
·
300 Posts
Probably the clock spring. It'll only reset once the problem has been permanently resolved. Have you lost any other steering wheel controls?

Sent from my SM-G950F using Tapatalk
 

·
Registered
Joined
·
43 Posts
Mines has the same problem and horn wont work either from steering wheel but the remote can still switch on the alarm so am quit certain it is clock spring. Mine does not have any code but a friend who has the same problem gets a code on his which points to the clock spring.
 

·
Registered
Joined
·
146 Posts
Discussion Starter #5
Probably the clock spring. It'll only reset once the problem has been permanently resolved. Have you lost any other steering wheel controls?

Sent from my SM-G950F using Tapatalk
all my other controls work horn, cruise control etc. I've reset it a few times. it can sit there with the engine running. for a while and there's no light. but soon as I start to drive it starts flashing.

Sent from my SM-A520F using Tapatalk
 

·
Registered
Joined
·
300 Posts
Yeah. Still think it's clock spring, but plug in and get it read to be certain.
Sometimes you find there's other problems that haven't been mentioned.

Sent from my SM-G950F using Tapatalk
 

·
Registered
Joined
·
42 Posts
Another vote for the clock spring. I had the same symptoms before my MOT. Banged an eBay clock spring in, did the light reset and all is well still. Pretty simple job, there is plenty of you tube videos!
 
1 - 7 of 7 Posts
Top