Nissan-Navara.net banner

21 - 27 of 27 Posts

·
Registered
Joined
·
38 Posts
I had this code with very small hole on main fuel line at tank.
what were your symptoms with that hole in the fuel pipes at the tank? I wonder if there is anything similar for me. I have a very loud engine. unique in winter. I replaced everything. injectors, pump and so on. rattling cold days ...
 

·
Registered
Joined
·
38 Posts
I had this code with very small hole on main fuel line at tank.
what were your symptoms with that hole in the fuel pipes at the tank? I wonder if there is anything similar for me. I have a very loud engine. unique in winter. I replaced everything. injectors, pump and so on. rattling cold days ...
 

·
Registered
Joined
·
38 Posts
Your correct D22 timing chain setup if bomb proof left alone. ( Its the D22 chain that is the upgrade on the D40) besides if it was the timing problem, I doubt your problem would be intermittent.
Nor do they have a DPF:eyeroll

Have you found any debris/water in the fuel filter at all.

I had an intermittent issue with my previous Pathfinder, went through the fuel system, I had air getting in from the injector leak off pipework, also found this black type slime on the pick up filter inside the fuel tank.
The fuel delivery pipe from the tank was under too much vacuum caused by the blind tank filter, air was getting sucked in at any weak point.
what were your symptoms with that hole in the fuel pipes at the tank? I wonder if there is anything similar for me. I have a very loud engine. unique in winter. I replaced everything. injectors, pump and so on. rattling cold days ...
 

·
Registered
Joined
·
57 Posts
I have extended crank when starting, a injector rattle around 3000rpm and at the flashing engine light with p77 code and every now and then it went into limp home huge plume of white smoke.
 

·
Registered
Joined
·
77 Posts
Hey all,
First real problem with my Navara. Bought at 65k, it drove spot on for 3000 miles, then the engine light started flashing towing a trailer uphill on the M6, and the engine started making an awful noise. I shut it off, fearing the worst (you know what I'm talking about) but after a good look it hadn't launched a rod through the block, so started and it drove fine, with no noise, for 1/2 mile to the next junction, where I left it and picked it up with the big trailer.
Took it to a nissan specialist (who was very good), where it was already booked in to do the bottom end. He read the code (fuel timing) put a new diesel filter on it and ran a load of diesel system cleaner through it, as well as put a fair couple of miles on it, which to solved it.

400 miles later I'm driving down the M6 again (no trailer this time), and it happens again. Check Engine Light flashes, engine sounds like a bag of spanners, and it won't do over 60mph. Drove home the back way, stopping about every 30 minutes when the CEL came on.
Code read this morning as 77 P7 Fuel Timing Control. Drove absolutely fine locally today. Priming it though, it does sound like there is air in the system for the first few pumps after a drive.



I picked up a new filter today, so am going to pull the filter tomorrow to see if it is full of **** again, as well as go through the lines for obvious faults. Otherwise, are there any other areas to look at? Most posts on this forum and elsewhere point to either the filter, or the injection pump (please no...).
I have access to a two poster lift, so can drop the tank if need be.
Had same code not long after buying mine, turned out was a tiny hole on metal pipe coming out of fuel tank that connects to fuel hoses. Luckily was enough pipe left to just cut off the bit with hole and reattach pipe, garage charged me about £100 to do which I thought fair considering the tank had to be dropped
 
21 - 27 of 27 Posts
Top