Nissan-Navara.net banner
1 - 4 of 4 Posts

·
Registered
Navara D40 2011 2.5 cdi
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi, I have a 2011 D40 2.5 cdi with 185000km. A bit of history. The engine wouldn't start when stationary for a while. Had to prime fuel first, then it would run fine. Found that the plastic water trap on primary fuel filter was cracked and leaking fuel. Replaced it and problem was over for a week. It then started stalling 30 seconds after start. I found the plastic drain **** on the secondary filter broken. Replaced this, and problems were over for a while. After some weeks it started stalling when ever revs were low. Have the rail pressure and suction control valve current checked. SCV current was all over with steady engine rpm. Engine died as soon as SCV current dropped to certain low value. Nissan SA quoted me ZAR3000 for new SCV, which I thought is a bit steep. So, I took the SCV off the engine and polished the plunger (I could see scuff marks on the plunger and it wasn't moving smooth/easy). Reinstalled the SCV and all my problems was gone. All went well for 3000km. Now the fuel filter is empty in the morning before startup etc.
So my questions are:
1. Does the SCV prevent fuel from running back to the fuel tank when engine is switched off?
2. Are there any other equipment preventing fuel from running back to fuel tank when engine is switched off?
3. How can I find correct fuel primer pump (in tank) without stripping fuel tank?
4. Apparently my vehicle is Thai spec - how can I know power outputs?
Thanks in advance.
Petrie
 

·
Administrator
Joined
·
15,348 Posts
1 No
2 No, it just relies on circuit being sealed
3 No primer pump
4 Not sure, somebody on here will know.

I suspect you have a further air leak. Check connections and the plastic T on the filter.
 

·
Registered
Navara D40 2011 2.5 cdi
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks "landmannnn", it looks like it was the rubber washer on the drain **** of the secondary filter. It was leaking, replaced it and it looks like it is fine now.
 
1 - 4 of 4 Posts
Top