Nissan-Navara.net banner
1 - 20 of 36 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #1 ·
Hi guys.
Navara D40..2009..129k
Ok guys,would be really grateful for your thoughts,as I,m at my wits end with this..
Took my nav in to garage,needed new cylinder head,and new head gasket..this was completed with a complete full service…also had new duplex trimming chains..
Collected my nav,after spending a fortune on it…worth it though,as it is immaculate..
It now drives absolutely perfect,no mis fire,no rough idle,does not mis a beat..computer says it averages 16 mpg….that’s around town…nav is only ever used driving around town…
The problem I now have,which I did not before..is black smoke coming out when accelerating..
When I say black smoke,I mean plumes of it..it fills the whole road behind,as where other vehicles have to stop,so bad can’t use my nav on the road…I also noticed a pinging noise when accelerating..
When idling it’s silent,no smoke,idles perfect,and very quite..perfect…no whistle from turbo..point that out..
So took back to garage,for investigation..
Garage contacts me and says injectors have been sent away,and all 4 are shot to pieces,in fact so bad..garage can’t make out how on earth the motor was running so well…
So to cure the black smoke,was told new injectors are needed..more expense..
So new injectors have been fitted..picked the motor up…but not completely smoke free still,drove it home..drives like brand new,but still giving out puffs of black smoke when accelerating,need to be clear on this..no where near as much as it did before..I can drive it without filling the road up with smoke..nevertheless after paying out so much money..I don’t expect it to give out any black smoke,or very little to say the least..but as said..still giving out a puff of black smoke..
Spoke to my garage team,whom I see as good guys,as they take care of my work vans..
Been advised by garage to take it on a long run…to blow it out?i,m not convinced this will cure the puffs of black smoke…but will give it a go….
In the meantime,any cures,suggestions,Imput,thoughts,remedies would be greatly appreciated from you guys…
Has my garage guys mis diagnosed with these injectors?
Because was told once new injectors fitted that would cure the black smoke problem..
Well it’s made it,by far much better,but not smoke free?
Thanks guys.
 

·
Administrator
Joined
·
16,670 Posts
Two things are likely to cause black smoke.
A faulty or dirty MAF. I would be surprised if the garage hadn't cleaned it.

A worn out boost control solenoid. One simple check is whether the turbo actuator is pulsing at idle.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #4 ·
Two things are likely to cause black smoke.
A faulty or dirty MAF. I would be surprised if the garage hadn't cleaned it.

A worn out boost control solenoid. One simple check is whether the turbo actuator is pulsing at idle.
Hi,.
Thanks for that..I bit naive around engines..how do I check if the turbo is pulsing?
Two things are likely to cause black smoke.
A faulty or dirty MAF. I would be surprised if the garage hadn't cleaned it.

A worn out boost control solenoid. One simple check is whether the turbo actuator is pulsing at idle.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #5 ·
Have you had the MAF sensor cleaned? Could be causing incorrect fueling
Hi.thanks
Not sure if it has?i,ve come across this problem before with maf,on a alpha gtv..not smoking..but running rough..didn’t bother cleaning just purchased a new one..
May go down that route..for the navara..worth a punt..is it an easy job on the navara or is it a garage thing
Thanks
 

·
Administrator
Joined
·
16,670 Posts
There is a circular thing on top of the turbo charger with a little rod underneath it.

A photo on this thread, not very clear
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #7 ·
Have you had the MAF sensor cleaned? Could be causing incorrect fueling
Hi.
Also..no engine check light on
No idle issues
No hard to start problems
No jerking
Fuel consumption ok
So maf issue not sure about?
As said she runs and drives like a dream..just these puff of black smoke issues
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #9 ·
Does it have a genuine Nissan air filter fitted just in case it’s a cheap aftermarket air filter installed causing a slight air intake restriction? Just a thought !!!
Hi,
Thanks for taking the time..
Not gen Nissan filter..but a very good quality well known brand..
Checked it ,very clean
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #10 ·
Update guys.
Have looked at maf and it’s spotless..looks new..and air filter very clean,and is new anyway…
Have been out in the motor earlier,when started no smoke at all..from cold..drive from cold for about 10 mins..no smoke,but after that starts puffing out smoke,when changing gear and accelerating.
Also a lot of soot in the tail pipe.
 

·
Banned
Joined
·
354 Posts
Pic of soot from inside tailpipe..weather it helps,to help me find a remedy to cure this.
Thanks guys…help needed…
Have seen cheap air filters in the past starting to collapse in the air filter box, It could be an issue with your turbo as was said, That’s why i prefer a boost gauge it gives you an idea how your turbo s performing, VNT Turbo s can have issues with carbon buildup in the mechanism some members have shortend the actuator rod and the black smoke has cleared it takes up the wear in the mechanism.
 

·
Banned
Joined
·
354 Posts
Also guys
I have no warning lights on….no loss of power..no whistle from turbo…
Faulty maf sensor would give you a lack of power might be better to get your garage to connect a test boost gauge on and take it on R/test climb a few hill under load and see what boost your getting it should peak at about 18psi the heavy soot indicates unburnt fuel which could be related to a turbo issue.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #20 ·
Hi guys.
I,m taking it on a good run next week,gonna cover about 100 miles,will see if this helps…not holding my breath mind you..and doubtfull
 
1 - 20 of 36 Posts
Top