Nissan-Navara.net banner
1 - 3 of 3 Posts

·
Registered
2011 YD25 Navara
Joined
·
2 Posts
Discussion Starter · #1 ·
I own a 2011 D40 with a YD25 engine with a 6 speed manual transmission.
I have been a long time lurker of this website and decided to make an account to see if anyone can help me or maybe I help someone.
I am having some issues with lack of power at low RPMs and also at high RPMs. When taking off in 1st gear, the truck is sluggish and requires a bit of throttle to get her moving.
At higher RPMs under constant throttle the boost peaks at ~20psi before dropping down to 15 sometimes 17 rapidly, where it stays. I can hear the turbo adjust the vanes and I get a noticeable drop in power.
I have scanned the vehicle and get no trouble codes. I have also attached a picture of my OBDs recording of one said incident.
For clarity, I had the turbo rebuilt this year because of faulty seals, I have cleaned the MAF, Throttle Body and replaced all (hopefully) of the vacuum hoses.
I guess my question is whether or not this behaviour is normal.
I also get a bit of smoke out the exhaust at these higher RPMs

Glad to be involved in the community!


Ecoregion Rectangle Light Product Azure
 

·
Administrator
Joined
·
15,622 Posts
Welcome along. It's just a couple of degrees here, so a bit jealous of you right now in the Caribbean.

Your graphs look spot on.

First check, is the fuel filter reasonably new?
Always worth running some injector cleaner through the tank of that hasn't been done recently.

You shouldn't get any smoke, the fact you are means that something isn't quite right.
I would next double check all the intake hoses for lose connections and splits.
 

·
Registered
2011 YD25 Navara
Joined
·
2 Posts
Discussion Starter · #3 ·
Welcome along. It's just a couple of degrees here, so a bit jealous of you right now in the Caribbean.

Your graphs look spot on.

First check, is the fuel filter reasonably new?
Always worth running some injector cleaner through the tank of that hasn't been done recently.

You shouldn't get any smoke, the fact you are means that something isn't quite right.
I would next double check all the intake hoses for lose connections and splits.
Thank you for the reply. Yes you can have some of our heat. It’s scorching hot the past week.

I have run some diesel treatment to see if it would help but to no avail. I will try some injector cleaner and double check the hoses.
will get back to you soon. Thanks again!
 
1 - 3 of 3 Posts
Top