Nissan-Navara.net banner

1 - 20 of 22 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Howdoo? 8)
Doe anyone have any tips for what to look at first for the above?
It used to be intermittent, but now it's not working at all, so should be easier to fix!
I'm thinking a bad connection on a sensor somewhere on the box? Fuses all tickety boo.

TIA.

Mick. :wink:
 

·
Registered
Joined
·
26 Posts
There is a small rubber flat grommet on the clutch pedal which pushes against a switch.Make sure it does not have an indentation or hole in it.The clutch switch needs to be fully pressed in when your foot is NOT on the pedal. Hope this helps.
 

·
Registered
Joined
·
211 Posts
Hi,

I've checked the grommet and the switch on the clutch goes in and out ok and the two on the break peddle also go in and out ok.

Whats next to try to get the cruise control working?

Cheers,

CS
 

·
Registered
Joined
·
54 Posts
hello mate try pushing your gear stick to the left if cruise works its ya park neutral switch mine does it
 

·
Registered
Joined
·
44 Posts
Hi have an 08 manual and seem to have the problem with the park/neutral switch - if hold gearlever to the left cruise is fine - as soon as let go gearlever cruise cuts out

Is the switch easy to replace or adjust ? If so any info on its location and how to would be much appreciated
 

·
Registered
Joined
·
211 Posts
papashaun said:
Hi have an 08 manual and seem to have the problem with the park/neutral switch - if hold gearlever to the left cruise is fine - as soon as let go gearlever cruise cuts out

Is the switch easy to replace or adjust ? If so any info on its location and how to would be much appreciated
I tested this today and the exact same thing happens.

OK when I hold the gear leaver to the left, it sets fine, release the gear lever and it deactivates

Any how to's on the park/natural switch replacement? Or a cost for a main dealer to sort?

Cheers,

CS
 

·
Registered
Joined
·
63 Posts
Discussion Starter #14
Hi Guys!

Sorry for the delay in replying, been very busy with work.
What a fantastic response! I'll check out the suggestions tommorrow, and update accordingly.

Thanks a bunch!
Mick.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #15
Yep! That's the baby! Pull the gearlever towards me (LHD remember?) and it works fine, let go, it trips out.

Thanks Guys! :thumbright:
 

·
Registered
Joined
·
5 Posts
hi guys well the news is
got new park/neutral switch put in the rubber grommet on the clutch pedal also appears to be ok
now the problem
IT STILL AINT WORKING
so guys any more ideas
 
1 - 20 of 22 Posts
Top