Nissan-Navara.net banner

1 - 13 of 13 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Greetings from Belize,



Please help! I started my vehicle in the morning to move it a couple of feet to load some garbage. After loading the garbage, I tried starting it to no avail. It only spins and wont start. The fuel tank is about 3/4 full, the manual pump get hard after a couple pumps. Anybody has a suggestion please.



Thank you. Arturo
 

·
Administrator
Joined
·
11,565 Posts
It might be worth taking out an injector but leaving it connected and seeing if it is squirting fuel (put it in a bottle otherwise it will get messy)
 

·
Administrator
Joined
·
11,565 Posts
It might be worth taking out an injector but leaving it connected and seeing if it is squirting fuel (put it in a bottle otherwise it will get messy)
Thank you for your response. I will try that tomorrow. Regards.
It is not unknown for these fuel pumps to fail, if so you should be able to find a second-hand one reasonably priced.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Hey,

Update: no fuel reaching the injectors, how to know if it is the fuel pump for sure? Could it be something else causing the pump not to work? Thanks.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #9
I am hoping its the sensor and not the pump. I am in the process of getting a sensor, but here in Belize, that is a bit challenging. I will let you know. Thank you


I couldn't register in the patrol forum. I dont get the verification email. FYI
 

·
Registered
Joined
·
19 Posts
Discussion Starter #11
Hi, it was the pump after all. I replaced it and now it is working.



It is really difficult and expensive to get one of those pumps here in Belize.



Thank you for all the input.
 
1 - 13 of 13 Posts
Top