Nissan-Navara.net banner

21 - 28 of 28 Posts

·
Registered
Joined
·
403 Posts
So I replaced the power steering tensioner pulley, the fan belt pulley and I've still got the noise. The noise still happens with the powrr steering belt off so it must be on the aux side. The noise is more prevalent if I listen on the left hand side of the fan body (not the alternator side) what else could it be?? The belt looks in good order but I guess I could try replacing it.
More than likely its the belt, mine sounded exactly like a bearing was gone but it was the belt
 

·
Registered
Joined
·
260 Posts
I had a bit of belt squeal on cold start up....

Turns out it was the bearing in the alernator pulley, I found out when the pulley came of.. made a hell of a bang !!
 

·
Registered
Joined
·
23 Posts
My nav goes back in tomoz guys for them to hunt this noise down as I said before they replaced my alternator so now tomoz is the belt and take it home see if the noise returns I'll keep you all updated
 

·
Registered
Joined
·
260 Posts
Update guys noise sorted ! Tensioner pulley replaced noise gone 😃

glad to hear you got it sorted, mine still makes a noise even after replacing belts/alternator/turbo/tensioner/water pump.

Leave's power steer pump, air con compressor and fan to replace... that'll be for the new owner as its up for sale and a new Ranger will be replacing it !!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #27
Replaced both belts and both tensioners now.. Still got the noise argh!!!!! I don't think it is the alternator of ac pulley. Could it be the fan pulley or the water pump??
 
21 - 28 of 28 Posts
Top