Nissan-Navara.net banner
1 - 7 of 7 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I’ve got a d40 2014 which has developed a rattle. Seems fine on tick over and only really seems to come on when warm. Seems quite metallic rattle but engine is running smooth if that makes sense.

trying to upload a video of it running but struggling to workout how?
 

· Administrator
Joined
·
17,495 Posts
Sounds a bit worse than I expected. It seems to have frequency around half of the engine revs, so I think camshaft or valve related. Possibly the top timing chain tensioner. I would be wary of driving it like that.

I think time to get a mechanic on it. Depending where you are there are a couple of specialists, Billcar in Shrewsbury and Kaisermotor in Kent. Generally both pretty helpful and would be much better than me at diagnosing the cause if you share the link.

If you have a good local garage use them of course!
 

· Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Sounds a bit worse than I expected. It seems to have frequency around half of the engine revs, so I think camshaft or valve related. Possibly the top timing chain tensioner. I would be wary of driving it like that.

I think time to get a mechanic on it. Depending where you are there are a couple of specialists, Billcar in Shrewsbury and Kaisermotor in Kent. Generally both pretty helpful and would be much better than me at diagnosing the cause if you share the link.

If you have a good local garage use them of course!
Thank you for taking the time to reply. Yes I agree that I don’t think it wants using. I’m based in West Yorkshire but I have used Billcar before on my v6 as the plastic oil drained under the turbo started leaking which is an engine out job 🤦🏻‍♂️!!

I’ve sent Dave a WhatsApp this morning but as yet he’s not replied, appreciate it is a Sunday however! Always going to be difficult to diagnose on a video too but I’ll see what he says.

once again thank you for your response.
Thanks Chris
 
1 - 7 of 7 Posts
Top