Nissan-Navara.net banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi All,

Had a weird problem last night which I want to try and figure out as it could potentially leave me stranded.

I drove normally to the shops (5 min drive). After stopping for 5 mins to go into shop, when I returned to the car ('07 PF 2.5DCI) and tried to start it the following happened:

1. Turn on ignition, dash lights up as normal;
2. Go to turn key to begin cranking engine - EVERYTHING goes DEAD - all lights out, no cranking attempted, just like someone pulled the terminal off the battery.
3. Turn ignition back off and on - dash lights up again, but this time, notice that trip computer/AC reset.
4. Repeat step 2 - 3 2x.
5. On 3rd attempt, waited just a few secs longer before trying to crank and it started as normal....

Any ideas on what could have caused this would be very welcome as the fear of being stranded is not good. The main thing that I find weird is that the whole car seemed to reset like the battery had been pulled.

For info, it has had a new battery and alternator in last few months, and starting has been excellent, so I don't think it is a charging issue.

Thanks in advance.

Jonr
 

·
Administrator
Joined
·
15,622 Posts
I would check the battery terminals are properly tight. Also the earth cable from the battery to the chassis/engine.

Also there is a master fuse on the positive battery terminal to check.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi Landmannnn, think you hit the nail on the head. Negative battery terminal was loose (somehow). Not off, just able to turn. Should have checked the obvious before posting really...

Thanks very much!
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top