Nissan-Navara.net banner

Electrical gremlin all electrics pulsing/ flashing.

226 Views 2 Replies 2 Participants Last post by  Obsolete897
Not new to navaras having issues my previous 2007 had plenty over the years. I bought 2013 navara and it developed a problem (there's a surprise šŸ¤¦) so in general it runs fine but after a short amount of time when idling it starts pulsating (front n rear lights, dash, radio etc.) We have changed the battery and alternator checked for loose earth cables (none visible) scanned it when it was doing it and no fault codes. Checked the battery and alternator when it was doing its thing and seemed fine. Question is does anyone know what it could possibly be? I have tried searching for answers and failed spectacularly.
1 - 1 of 3 Posts
Not new to navaras having issues my previous 2007 had plenty over the years. I bought 2013 navara and it developed a problem (there's a surprise šŸ¤¦) so in general it runs fine but after a short amount of time when idling it starts pulsating (front n rear lights, dash, radio etc.) We have changed the battery and alternator checked for loose earth cables (none visible) scanned it when it was doing it and no fault codes. Checked the battery and alternator when it was doing its thing and seemed fine. Question is does anyone know what it could possibly be? I have tried searching for answers and failed spectacularly.
Welcome to the forum...

It does sound like a poor earth somewhere.

One area some people have found is the bunch of connectors behind the panel to the right of the throttle pedal. (You need to lift the threshold strip to get it open)
1 - 1 of 3 Posts
Top