Nissan-Navara.net banner

1 - 15 of 15 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
My truck died on me and now wont start. There are no errors shown when dong the pedal dance.
Turns over ok but no sign of life.

Anyone have any ideas


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
97 Posts
Discussion Starter #3 (Edited)
Thanks for the reply, finally the rain stopped long enough to try the injector test.
I used a spare injector i had, no fuel emitting while cranking.
Even with the injector not connected there is no fuel coming out of the pipe.
I took off the fuel filter and that was full of diesel ok.
Is there a way to know if the tank fuel pump is working?
 

·
Registered
Joined
·
97 Posts
Discussion Starter #5
Do you mean the knob on top of the filter? It don’t feel any different when pumping, but i did press it when the filter was off and the fuel was squirting out a lot on every pump


Sent from my iPhone using Tapatalk
 

·
Administrator
Joined
·
12,315 Posts
The D40 has a bulb under the filter, of you pump it a few times it will get hard unless there is an air leak.

I can't picture a version with a knob.

I think the most likely culprit is an air leak.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #7
Should there be fuel emitted out of one of the fuel pipes leading to the filter while ignition is on and/or cranking
Both pipes are dry



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
97 Posts
Discussion Starter #8
I don’t think there is a tank fuel pump, the hand pump works fine to prime it.
The high pressure fuel pump must also suck the fuel from the tank.
Would a failure of pressure regulator on the back of the pump stop the engine from starting?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
97 Posts
Discussion Starter #10
There isn’t a bulb just A knob on top of the filter which when pushed down quirts fuel out of the large hose when removed.


Sent from my iPhone using Tapatalk
 

·
Administrator
Joined
·
12,315 Posts
I see, you have the one with a water separator and a plug into the wiring loom?
Very few came to the UK with that.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #12
Well it turns out to be more dramatic than just not starting.
I finally noticed that when cranking the pulley was not turning continuously.
Pulled out the engine to find the flywheel has broken.



Could there be something wrong with the auto box that has made this sheer off?
The inner splines behind the torque converter turns freely by hand and if i push the truck it also turns.
The outer spline is solid and does not turn is this correct?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
97 Posts
Discussion Starter #14
Nissan main dealer said the same, he has never supplied one before, guess thats why they want £1350 for a new one.


Sent from my iPhone using Tapatalk
 
1 - 15 of 15 Posts
Top