Nissan-Navara.net banner
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi guys I've got a issue with my nav auto gearbox it's got no drive previous to this it was very sluggish to pull away from a junction I was told to change the atf and remove and clean thoroughly the valve body I stupidly used brake cleaner on the valve body/tcm/and solenoids when I fitted it back into the truck its got no drive I've had it scanned today by a mechanic and it has brought up some fault codes solenoid faults and some brake faults codes I've been told that these codes are a bad valve body and or tcm I've found a replacement valve body with tcm and all solenoids on line will this need programming or will it just work
 

· Administrator
Joined
·
17,495 Posts
Hi guys I've got a issue with my nav auto gearbox it's got no drive previous to this it was very sluggish to pull away from a junction I was told to change the atf and remove and clean thoroughly the valve body I stupidly used brake cleaner on the valve body/tcm/and solenoids when I fitted it back into the truck its got no drive I've had it scanned today by a mechanic and it has brought up some fault codes solenoid faults and some brake faults codes I've been told that these codes are a bad valve body and or tcm I've found a replacement valve body with tcm and all solenoids on line will this need programming or will it just work
Fortunately no programming needed.

Brake cleaner and rubber are not the best of friends!
 
1 - 2 of 2 Posts
Top