Nissan-Navara.net banner

21 - 25 of 25 Posts

·
Registered
Joined
·
44 Posts
Yep, particularly at 41 mph it can't make its mind up. 42 is ok.
I do a lot of driving at 40mph and find this extremely annoying, I feel this engine would comfortably cope with changes 5mph earlier.....after all you still have S mode if you need to go like a bat out of hell!
 

·
Registered
Joined
·
13 Posts
manual mode unavailable sometimes

how do guys, i have a similar problem but mine is intermittent. half the time it works and half the time it doesn't. so if i start the jeep, move down to D and then across, if the "S" doesn't appear, i turn off ignition and restart again and its then it comes back. once or twice i checked first before setting off and then down the road went to move into manual/sport mode and it did nothing. i notice when its not working too as gear change is very sluggish and i try to move to manual to downshift to overtake and notice i can't change manually. this only happens sometimes now. when plugging into it it shows no faults with gearbox or engine. just a simple cycle of the key seems to reset the issue. could it be a comms issue or gearbox fluid need changing or something? when it happens power is fairly retarded.
 

·
Administrator
Joined
·
11,702 Posts
It is possible that the truck is detecting an issue and restricting power. You can't read AT codes without specialist kit, so there may be a fault pending.
It might be useful to get someone to read the AT codes for you.
 

·
Registered
Joined
·
1 Posts
Hi MJM.
This my first post on this forum, & felt I needed share what happened to me.
I've had the same problem with my Australian delivered 2011 Navara D40 ST-X 550, buying it secondhand!
This process took around 9-10 weeks.
I lost track really, because there was no info out there regarding this. Very frustrating!
It has been a very difficult and lengthy journey, trying to problem solve the issue, to establish the cause and faulty part/s.
Why did my 7sp gearbox not go into sports shift mode/manual shift mode, even though I was moving the lever etc!
I have a mechanical background, being and Aircraft Maintenance Engineer by trade, and do all the work on my one vehicles where possible!
In this case, it was taken to my local mechanic, who repairs and services a large number of Nissan Navara's here in Perth, Western Australia!
He identified the first broken part as the gear shift micro switches, in the gear lever shift tree.
They are tripped when moving the lever over to sport shift mode. This/these micro switches were faulty, according to the fault codes!
The switches can't be replaced individually, but comes as a complete shift tree, unfortunately!
This is quite expensive at around + AU$900 for the part & installation.
This did not, however, rectify the problem! By this time I was starting to get worried!!!
2nd part to come guys.


Sent from my iPhone using Tapatalk
Hi MJM.
This my first post on this forum, & felt I needed share what happened to me.
I've had the same problem with my Australian delivered 2011 Navara D40 ST-X 550, buying it secondhand!
This process took around 9-10 weeks.
I lost track really, because there was no info out there regarding this. Very frustrating!
It has been a very difficult and lengthy journey, trying to problem solve the issue, to establish the cause and faulty part/s.
Why did my 7sp gearbox not go into sports shift mode/manual shift mode, even though I was moving the lever etc!
I have a mechanical background, being and Aircraft Maintenance Engineer by trade, and do all the work on my one vehicles where possible!
In this case, it was taken to my local mechanic, who repairs and services a large number of Nissan Navara's here in Perth, Western Australia!
He identified the first broken part as the gear shift micro switches, in the gear lever shift tree.
They are tripped when moving the lever over to sport shift mode. This/these micro switches were faulty, according to the fault codes!
The switches can't be replaced individually, but comes as a complete shift tree, unfortunately!
This is quite expensive at around + AU$900 for the part & installation.
This did not, however, rectify the problem! By this time I was starting to get worried!!!
2nd part to come guys.


Sent from my iPhone using Tapatalk
Hi Torrem77, Did you ever mange to get to the bottom of this? I have the exact same problem popping up now and cant pinpoint what the cause nay be. The Nissan dealers are also not sure what to think of it?

Thanks
 
21 - 25 of 25 Posts
Top