Nissan-Navara.net banner

1 - 20 of 36 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter #1
My 07 aventura stalls about 3 seconds after starting it, occasionally! Sometimes it throws up a fault code and other times it doesn't.

Anyone know how to actually remove the EGR valve to give it a really thorough clean out? I want to try this before spending the cash to replace it. Any help would be awesome ??
 

·
Registered
Joined
·
1,319 Posts
Just blank it, mine did the same but didnt stall just kept throwing up faults not done it since
 

·
Registered
Joined
·
1,319 Posts
and your 100% sure its saying EGR fault? if so they just unbolt some swear by oven cleaner to clean it never bothered myself, do you have erratic idle at all?
It could be air in the fuel system do you have a nissan fuel filter or a pattern one?
 

·
Registered
Joined
·
101 Posts
Discussion Starter #6
I think it's an EGR fault just because when it does throw up a code it relates to the EGR. I did have a bad erratic idle and stalling but the got a new suction control valve for the fuel pump and it was all sorted. That was about a month ago and now it's doing the stall thing occasionally. Not sure on the fuel filter and also don't know about air in the system. What would you suggest I try? Cheers
 

·
Premium Member
Joined
·
15,733 Posts
The only thing that would hold it in place after the previous instructions would be the coolant pipes, clamp and disconnect them and the valve will be free. You'll need to bleed the coolant afterwards.

To be honest if you've cleaned it already and it's still trowing up a fault code, you need to replace the valve.
 

·
Administrator
Joined
·
12,349 Posts
They aren't hugely expensive, £150 for genuine on milneroffroad, not sure about quality, but pattern around half of that on fleebay.
 

·
Registered
Joined
·
101 Posts
Discussion Starter #13
More problems!!

I just replaced the EGR valve with a new one... I put the truck into the diagnostic mode and held the accelerator for 10 secs to reset everything. It started and I took it for a small test drive. When I turned the truck off it struggled to start again and I got the fault code 1272.

I cleared that and managed to start it but it keeps stalling 3secs after starting pretty much all the time! Any help would be greatly appreciated Im at a loss now!
 

·
Premium Member
Joined
·
15,733 Posts
This is a strange one. the fault code generally relates to the SCV. :faint

Where did you get the new valve come from?

Have you fitted an EGR blank?

It might be worth doing a hard reset, disconnect the battery terminals and touch the wires together to dissipate any residual current in the ECU.
 

·
Registered
Joined
·
101 Posts
Discussion Starter #15
I got the EGR from eBay for around £90, the seller had sold lots of them so figured it was a go-to choice. Yeah I've replaced the SCV previously so that 'should' be fine. I'll try the hard reset now. Could it be the fuel filter?
 

·
Registered
Joined
·
1,319 Posts
just because your SCV is replaced dont assume its ok, i have done mine and am getting symptoms again of it being faulty but i will work my way through the sensors to make sure it is, this time i will take it off and have it tested at my local DERV specialist which he can do for a small fee if its goosed i will get a new one off him return the other which is under warranty and have the Diag for free seems a fair swap to me.

Out of curiosity have you tried pumping the fuel bulb what your describing could be fuel starvation due to a air leak overnight
 

·
Registered
Joined
·
101 Posts
Discussion Starter #18
where is the bulb? I had a look on the fuel filter but it only has a plastic screw on the side but no bulb
 

·
Registered
Joined
·
101 Posts
Discussion Starter #19
Ah I found it. Unfortunately that didn't help! dont know what to try next. Worth changing the fuel filter?
 
1 - 20 of 36 Posts
Top