Nissan-Navara.net banner
1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hi there I have rebuilt my nav d22 yd25ddti and now have a noise can any one tell me what it is? I am worried I have fitted the incorrect size or quality of con rod big end bearings or not notice damage to another rod. However thought I'd put it on here incase it's something else so I can check everything and try again. I can't upload a video on here though so don't know how to share it but. it's starts fine has oil pressure the noise sounds piston slap/ rod knock I can feel it through the clutch pedal if I accelerate a the noise is parallel to revolutions as in increases frequency with the increased frequency of revolutions. Could old diesel say been in tank 5 months cause a diesel knock you can feel or is it an injector or most likely rod knock.
I have replaced one rod and all big end bearings with ispn dual metal shells not copper ones and now think I should have. Engine runs with no malfunction lights on. Oil light to off straight away (within 10 seconds) on first start and even less everytime after that.
As engine warms noise gets louder.
I worried that I may have stretched the timing chain trying to toque the crank bolt as I tried first with I in gear and torque wrench on the brake peddle wedged on by the seat. Then used a piece of angle iron in the starter Motor hole as this gave me no movement of crank during tightening process. I'm not worried about taking it apart again just what to check as much as possible while it's running incase it's something else.
 

·
Administrator
Joined
·
15,144 Posts
Not great. I think it is very unlikely that you have stretched the timing chain.
More likely some play in a main or big end bearing, I think you will have to strip it down again.
 

·
Registered
Joined
·
27 Posts
did you check the piston small end pins for side tilt they my be out of spec
just add to rebuild my engine like yours it started first time and after about 10 sec engine add
a top end knock it got louder when it pulled of then it went and comes back on tic over
i have also just got thrust washers old ones were badly worn wot i need to know now is how mutch
end play on the crank
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
I have fixed it the main bearing cap bolts stretched and had to be replaced but all sorted now passed its MOT today. I'm well chuffed and just in tim or my birthday.
Not having a motor sucks,
However driving a nav you rebuild yourself PRICELESS!( Vehicle and parts total cost £900 )
 
1 - 5 of 5 Posts
Top