Nissan-Navara.net banner
1 - 6 of 6 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 · (Edited)
Hi guys, i got a d22 2012 2.5 and i am having trouble with losing power when i get round 3000ish revs i can't get any more power even when my foot is flat. Only happens when im travel round 110km. Sometimes when i take my foot the pedal and back on again it fixes it. Anyone had this problem? im at a loss Can't figure it out..
Thanks 馃憤
 

Administrator
Joined
15,479 Posts
Have a read here
 

Registered
Joined
3 Posts
Discussion Starter · #3 ·
Have a read here

Good read mate thank you. I have crossed that list of already, i blocked my EGR about 6 months ago and it fixed it untill now, i have changed fuel filter and cleaned air sensors. Car was going in to limp mode a couple of weeks ago, i took the module off what i put on hoping it was that. It fixed the limp mode side of things, now lacking power again..
Who knows 馃し鈥嶁檧锔
Chrees mate
 

Administrator
Joined
15,479 Posts
I've normally found a good quality fuel filter, a MAF clean and some injector cleaner through the tank helps a lot.
 

Registered
Joined
2 Posts
Hi guys, i got a d22 2012 2.5 and i am having trouble with losing power when i get round 3000ish revs i can't get any more power even when my foot is flat. Only happens when im travel round 110km. Sometimes when i take my foot the pedal and back on again it fixes it. Anyone had this problem? im at a loss Can't figure it out..
Thanks 馃憤
 

Registered
Joined
2 Posts
Have you changed the timing chain? A recent earlier signs like this was the timing chain needed replacement.
 
1 - 6 of 6 Posts
Top