Nissan-Navara.net banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi everyone!
Hope everyone is fine and healthy.

I got a Navara D40 2009 2.5 diesel and for a few months now I've been experiencing a low beam dash indicator problem. When the car is completely turned off, the indicator blinks sometimes, not fully lit, just blinks like there is a little current leak. When I start the engine, I notice that the indicator blinks even more, maybe for the vibration. And when I turn on the headlights, the indicator works fine, fully lit.

I did not give it much importance because it does not always do it, but lately it is more constant. Where should I take a look? Any headlight diagram?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
No, it's basically stock. The only change was a Pioneer SPH DA-120 stereo, but was replaced because the touch screen was damaged. The indicator malfunction happened a couple months later when I put the original car stereo.
 

·
Administrator
Joined
·
4,816 Posts
First things first I'd pull the headlight fuse. see if that shuts the dash light off.
If it dosnt then there is a short somewhere letting power into the circuit .
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Update: Even took the dashboard fuse out and the indicator still blinked. When the lights were turned on (with dashboard fuse out), the indicator did stopped blinking and went “black”, all fine there. I have a multimeter, is this enough to find the short?
 
1 - 6 of 6 Posts
Top