Nissan-Navara.net banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1 (Edited)
I took my zd30 to a mechanic regarding a misfire, it happens intermittently, as in it runs fine but seems to jump a beat usually around 2-2500 revs but always does biger jumps of loss of power above 3000 revs when the turbo kicks in. I was told the fuel pump is failing and burning fuel at 130 degrees Celsius. But this can also misfire when the engine is cold but not as bad. this makes me wonder if it's just high temp causing this and if it is the fuel pump why would it still start as I've read that these types of engines with fuel pumps don't gradually fail but just die and this would cause no starting or running in general. The mechanic told me it wouldn't cause any harm to the engine but obviously causes a big drop in power. Has anyone got any ideas what this could be from and if I definitely need a new fuel pump as I don't wanna spend crazy money on something I'm unsure about. I also got the fuel filter cchnaged to see if it'd help but didn't and after bleeding the injectors from the top nuts at the top of the engine block, it started leaking oil, not fuel definitely oil, I don't think it's from inector nuts as a pipe was disconnected and I'm not sure if this was leaking oil or not but I've reconnected it and going to wash the engine to see if more oil will leak, or if I'm currently seeing oil dripping from when this pipe was disconnected, but it's coming from near these nuts and where these pipes were. I'm not very smart with engines, but I don't see this anywhere near normal . I will post pictures in the morning.sorry for mistakes I'm using a phone to type this.
 
1 - 8 of 8 Posts
Top