Nissan-Navara.net banner

1 - 20 of 27 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1 (Edited)
Hi. If anyone here can guide me with my nav symptoms.
It would be really appreciated

Did the dance pedal and a code is 0089 sound like a fuel problem.

I have lumpy start it's takes few attempts to start it, its judering like I am on horse carage but if I press the accelerator hard the judering it's not that noticable also a tapping noise, poor fuel economy and underpower.
So far I have change fuel filter but still with the same issue. I bought primer bulb and some new fuel tubes hope that will help as I have heard if you got a crack in the fuel line it tends to draw air in. I also bought today denso SCV and hopefully that will help..
 

·
Administrator
Joined
·
12,349 Posts
P0089 means the SCV needs replacing in the vast majority of cases. One tip, take the rh wheel off and the inner panel to access the SCV.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
P0089 means the SCV needs replacing in the vast majority of cases. One tip, take the rh wheel off and the inner panel to access the SCV.
Hi, thank you for you reply.
I tough I could get access from above by losing the oil dipstick and hopefully have some access to it? But definitely your idea is well worth doing. Do you know how long does it takes to do the job? Also do I have to pay any attention on to how re-installed and whether do I need to do reset ECU or hard reset?
Regards
 

·
Administrator
Joined
·
12,349 Posts
You can get access from above true. Various write ups on here have confirmed that it is quicker and easier to do the wheelarch method.

Correct that a fuel pump reset is required, the pedal dance.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Righ took me about 1 hour start to finish changing the SCV from above the engine. Unfortunately the symptoms are still the same. Also reset the ECU! Am lost now and wonder what else could be wrong with it?!?!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Yes I did and funny thing there is no code now the first sequence is slow then the rest is fast but all in 0000??
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
Hi again.
Do you have any thoughts on that?
I have clean the maf sensor with electro spray as it was very dirty and install new air filter and now wont even start just keeps cranking and eventually the battery died
 

·
Administrator
Joined
·
12,349 Posts
If you squeeze the fuel pump bulb does it get hard? By the way it will run with the MAF disconnected.
 

·
Registered
2009 D40
Joined
·
35 Posts
Whats this pedal dance you all talk about? ? I getting all sort of images in my mind.....
 

·
Administrator
Joined
·
12,349 Posts
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
If you squeeze the fuel pump bulb does it get hard? By the way it will run with the MAF disconnected.
Hi Landmannnn.
Yes after 3 or 4 presses but if you leave for for few minutes its gets soft again! Are meant to stay hard or is this normal
 

·
Registered
Joined
·
14 Posts
Discussion Starter #14
Alright ok good to know. Do you what else I could check as am still having issue with nav d40 since I clean the maf sensor wont start!
Is there a way to check the chain tensioner without breaking any deals?
Regards
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
Quick update guys.
Iv changed the primer bulb and found that had 3 diferent splits so I guess it was sucking air. Tried to crank the engine and eventually started but still was that judering and tapping/hissing noise however that tapping/ hissing noise is air related I believe Iv disconnect the intercooler pipe and the sound was same but alot louder then I disconet the egr and the judering was less and the tapping or hising noise decrease a bit so wonder if I need to clean the egr and check for air leak in the intercooler system etc.
Regards
 

·
Registered
Joined
·
14 Posts
Discussion Starter #17
Landmannnn.
Do you reckon I can just blank it off without bringing any codes up. Or does it need deleting from the ecu with a remap?
Regards
 

·
Registered
Joined
·
14 Posts
Discussion Starter #19
Nice one it turns out I got 2007 happy days? hope fully it will fix the problem with my truck. Is there any way I can remove the cover to check the timing chain and to see if it's been done or loss with out damaging any seals?
Regards
 
1 - 20 of 27 Posts
Top