Nissan-Navara.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all,i have a 2019 ngaurd,did a 250mile trip only to have found engine wet with oil,coming from boost pipe from turbo,it only has 3500miles,nissan has replaced pipe and is ok,although i question there shouldnt be that amount of oil there unless the turbo was passing oil.did some digging and hear a few people having had pipe replaced 2/3times due to warping,didnt fine much much on turbo failure, just wondering is anyone else having any problems?
 

Attachments

·
Premium Member
Joined
·
2,383 Posts
My pipe looks exactly like that. Not worried.

I have replaced mine once (within weeks of purchase) because the boost controller failed and split that pipe through overpressure.

The split was immediately obvious - it sounds like a 747 taking off in your engine bay. If you think “I’m not sure if I’ve heard that or not”, you haven’t heard it!
 

·
Registered
Joined
·
1 Posts
Hi all,i have a 2019 ngaurd,did a 250mile trip only to have found engine wet with oil,coming from boost pipe from turbo,it only has 3500miles,nissan has replaced pipe and is ok,although i question there shouldnt be that amount of oil there unless the turbo was passing oil.did some digging and hear a few people having had pipe replaced 2/3times due to warping,didnt fine much much on turbo failure, just wondering is anyone else having any problems?
I have just noticed the same problem with my np300 yesterday. Looks like oil leaking from the turbo pipe and starting to show spots on my driveway. Going to book in with the dealer service dept asap
How did they go about fixing it for you and was it covered under warranty??
Xmas break is 4 days away and I really need my car
 

·
Registered
Joined
·
2 Posts
Hi all,i have a 2019 ngaurd,did a 250mile trip only to have found engine wet with oil,coming from boost pipe from turbo,it only has 3500miles,nissan has replaced pipe and is ok,although i question there shouldnt be that amount of oil there unless the turbo was passing oil.did some digging and hear a few people having had pipe replaced 2/3times due to warping,didnt fine much much on turbo failure, just wondering is anyone else having any problems?
Replacing the hot pipe will fix the problem. Had the same issue after 120K.
 
1 - 7 of 7 Posts
Top