Nissan-Navara.net banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Been having some running issues recently with my NP300.

The other day it started sounding noisy at certain revs, a sort of clacking sound, pretty much just like a land rover TD5 sounds all the time. This would happen now and again and some days not at all. The engine warning light, traction control and collision avoidance lights come on.

Yesterday it happened again and wouldn't go away and now won't start at all. There's not smoke at all.

Any ideas what it might be or has anyone experienced this?

Thanks in advance.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Thanks, it did come with warranty from the dealer and will be looked at next Wednesday but need it for work daily.
Where is the socket to plug in the scanner?
 

·
Administrator
Joined
·
4,911 Posts
Are all the visible belts tight?
If it was a d40 I'd be saying streched timing chain!
 

·
Administrator
Joined
·
4,911 Posts
Usually yes but d40 chains have been known to go without warning
However I've not really heard of chain problems on the np300's
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
Thanks for all the comments.

Just to update, I was starting to dispair as I use the truck for work, my local garage wasn’t interested and Nissan could only see it on October 4th!

From what I read online the first thing a garage would do is change the fuel filter so I ordered one. When I got the old one out it was filthy and the manufacture date was 2016! So safe to assume this is the one it left the factory with.
After some turning over, followed by a fair bit of smoke and engine noise it finally cleared as did the warning lights and it’s running great! Fixed for £26 result!

Grass Cylinder Gas Plastic Metal
 
1 - 8 of 8 Posts
Top