Nissan-Navara.net banner
1 - 18 of 18 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, I have just bought a 2016 navara tekna with 44k. When I got it home I’ve spotted a small pool of oil on top of the turbo which looks like it’s came from a leaking seal / o ring on the turbo hot pipe.

Is it possible to get replacement o rings for this pipe or is it a complete replacement hot pipe?
I have been struggling to find any uk suppliers online and was wondering if anyone here has had same issues and could recommend where to source parts?

Thanks in advance, new to this forum and new to navara’s.
 

·
Administrator
Joined
·
16,672 Posts
Have you had a look to see if it just a case of the joints not seated correctly?

Probably the easiest way to buy o rings is to measure them and find a supplier who can provide that size. Saying that I would be tempted to use some instant gasket!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Have you had a look to see if it just a case of the joints not seated correctly?

Probably the easiest way to buy o rings is to measure them and find a supplier who can provide that size. Saying that I would be tempted to use some instant gasket!
Yes joint seems to be made fine but o ring still leaking. You can only buy the whole pipe from Nissan after calling them today so I will measure the o ring and try that way first I think thanks
 

·
Registered
Joined
·
520 Posts
It's a funny wiper type seal which is hard to find. I used a standard wiper seal and it worked fine for a while.
If you look carefully you will see the pipe doesn't seat 100% and that's where the problem lies. The newer pipes and pipes off the 2018 onwards have a slight adjustment so they seal property.
 

·
Registered
Joined
·
4 Posts
Hi, I have just bought a 2016 navara tekna with 44k. When I got it home I’ve spotted a small pool of oil on top of the turbo which looks like it’s came from a leaking seal / o ring on the turbo hot pipe.

Is it possible to get replacement o rings for this pipe or is it a complete replacement hot pipe?
I have been struggling to find any uk suppliers online and was wondering if anyone here has had same issues and could recommend where to source parts?

Thanks in advance, new to this forum and new to navara’s.
Hi I have also just purchased the same navara and I have exactly the same problem. Have you had it fixed?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Hi I have also just purchased the same navara and I have exactly the same problem. Have you had it fixed?
Not yet, I bought a new pipe from Nissan as the seal wasn’t available itself. I fitted it and it was fine for two days, day three it started leaking again so currently waiting on an answer back from them at the moment
 

·
Registered
Joined
·
4 Posts
Not yet, I bought a new pipe from Nissan as the seal wasn’t available itself. I fitted it and it was fine for two days, day three it started leaking again so currently waiting on an answer back from them at the moment
Thanks for your reply. when mine was in for a service the mechanic did re seal the pipe but it did not work. I was thinking of replacing the pipe so thanks for the info on that. I will let you know how i get on, if you could let me know how you go that would be great.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
Thanks for your reply. when mine was in for a service the mechanic did re seal the pipe but it did not work. I was thinking of replacing the pipe so thanks for the info on that. I will let you know how i get on, if you could let me know how you go that would be great.
Just to give you a quick update, that’s two new pipes I’ve had fitted. Genuine part from Nissan. They thought it may have been a faulty batch to start with. But yet again, after two days that’s the new pipe leaking from the seal. I’m not entirely sure where to go from here with it. I have purchased two orings as an experiment to try with my old pipe but still waiting for them to arrive just now.
Have you had any progress with yours?
 

·
Registered
Joined
·
4 Posts
Just to give you a quick update, that’s two new pipes I’ve had fitted. Genuine part from Nissan. They thought it may have been a faulty batch to start with. But yet again, after two days that’s the new pipe leaking from the seal. I’m not entirely sure where to go from here with it. I have purchased two orings as an experiment to try with my old pipe but still waiting for them to arrive just now.
Have you had any progress with yours?
Hi Thanks for the update. I am currently in discussion with NISSAN UK I discovered my oil leak when the vehicle had 10 days warranty left and I was told by the local dealer that they could not do it before the warranty had expired ( the person I spoke to at the dealers indicated to me that it was a well known fault) so I have taken it up with Nissan directly. I will let you know the outcome.
 

·
Registered
Joined
·
7 Posts
I had the same Issue with mine @ 55000kms(2016 warrior), Nissan wouldn't warranty it(or well the local dealer), it seems the pipe gets heat warped for the first gen pipes., i ended up buying a custom pipe from CRG fab in Australia and been mint so far just as an option (cost about $100nzd for more than buying a factory pipe inc shipping)
 

·
Registered
Joined
·
1 Posts
Hi Lads, just joined the forum
Enjoying my NP300 for 2 years until this fault!
@Albania 🇦🇱 Did you have a part number for the seal?
Found a part number for a Nissan/Renault 2.3 but the picture is just generic
part number I found is: 1655800Q0A
Is that the same as the number you used?
 
1 - 18 of 18 Posts
Top