Nissan-Navara.net banner

1 - 20 of 23 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi new to all this just in a bit of bother and could do with a bit of help if any of you don’t mind please. I brought a navara d40 2015 v6 auto done 30000. But it’s got a oil leak I cleaned all the oil off so all fresh. Ran the truck on the drive for half a hour got underneath it and the oil had run round both sides of the bell housing. At first I thought it’s the crank seal but have put a cotton bud inside the cut out at the bottom of the bell housing at its dry so not the crank seal. I have had a inspection camera on top of the bell housing but can’t see nothing. I just can’t work out if it’s a rocker cover gasket, head gasket or a pipe off the bottom of the turbo. Is it a fault or anyone heard of this problem? And it isn’t the o ring on the bottom of the dip stick, already done that one haha. Thanks for having the time to read this cheers
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
I am either going to have to take the box’s off to get to look at it or take turbo off with I believe is engine out to get the turbo off?

I have just read the introduction and I do Apologise for not introduction get my self I won’t put a picture of my truck on and my address as I don’t like stuff like that but thank you for answering my question
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Hi I am sorry for this post but I am struggling and need to pick your brains as I think this is my last hope. I will be honest with you I have joined to see if some1 can help me as a friend told me to. I have never been on something like this but I have been looking though all the chats about the d40 and I like how every1 helps each other thought the thick and thin fair play. I am defo going to keep on hear and maybe I can help out to. I feel bad to ask as I am new to the forum but I really do need your experience. Basically I have a Nissan navara d40 v6 2015 auto 30000 and I have a oil leak now it it coming from the middle of top of the bell housing and running down the bell housing to the bottom. More on the nearside, it isn’t the crank seal as I have put a cotton bud in the hole of the bottom of the bell housing and it was dry. The head gasket looks dry, I looks to me to either be rocker cover seal of something to do with the turbo but I just can’t see nothing. Is there a common fault or have I got to pull either the boxes out or take the engine out? As the book says 16hours to get the turbo off and 16 to take the engine out so I presume the engine has to come out to get the turbo out. Any help would be more than appreciated and I hope one day soon I can return the faver. Thanks very much banni[/QUOTE]
 

·
Administrator
Joined
·
4,816 Posts
As the book says 16hours to get the turbo off and 16 to take the engine out
16 hours to get the turbo off? holly hell its about 45minutes on the 2.5 and maybe another hour and half later the engine would be out too!
 

·
Administrator
Joined
·
14,715 Posts
Hi I am sorry for this post but I am struggling and need to pick your brains as I think this is my last hope. I will be honest with you I have joined to see if some1 can help me as a friend told me to. I have never been on something like this but I have been looking though all the chats about the d40 and I like how every1 helps each other thought the thick and thin fair play. I am defo going to keep on hear and maybe I can help out to. I feel bad to ask as I am new to the forum but I really do need your experience. Basically I have a Nissan navara d40 v6 2015 auto 30000 and I have a oil leak now it it coming from the middle of top of the bell housing and running down the bell housing to the bottom. More on the nearside, it isn’t the crank seal as I have put a cotton bud in the hole of the bottom of the bell housing and it was dry. The head gasket looks dry, I looks to me to either be rocker cover seal of something to do with the turbo but I just can’t see nothing. Is there a common fault or have I got to pull either the boxes out or take the engine out? As the book says 16hours to get the turbo off and 16 to take the engine out so I presume the engine has to come out to get the turbo out. Any help would be more than appreciated and I hope one day soon I can return the faver. Thanks very much banni
[/QUOTE]

The V6 is normally pretty trouble free, it does sound like there might be an oil leak on the turbo.

I would suggest you buy a cheap borescope - something that will let you see up in the turbo area. You can even get one as a mobile phone attachment.
 

·
Registered
Joined
·
2,724 Posts
Many things to check before pulling the engine. One place to try for a borescope/endoscope:

[ame]https://www.amazon.co.uk/s/ref=nb_sb_ss_i_5_10?url=search-alias%3Daps&field-keywords=inspection+camera+with+light&sprefix=inspection%2Caps%2C389&crid=272VSV1U0BAI4&rh=i%3Aaps%2Ck%3Ainspection+camera+with+light&ajr=0[/ame]
 

·
Registered
Joined
·
2,724 Posts
Has the crankcase breather tube come off perhaps?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #11 ·
Sorry for the delay forgot my password lol. I have tried to get a camera down there just can’t see nothing. Will have one more go and if not going to have to take the gearbox out I think not what I want but can’t see any option thanks
 

·
Registered
Joined
·
2 Posts
Sounds like the same issue with my STX550, oil only leaks when motor is running with a very wet bell housing.
I have used an inspection cam and 5 hours in with the mechanic and still can not find it, and it does not look to be blow by. Top of the motor looks clean but oil is from the top.
One thought was a rear main but that should not throw oil like at the top side.

The only thing I can now think of is the rocker cover gasket on the left hand side. If any one has found this issue I would be keen to know what it was.

I have pull the font of the turbo off and inspected most places I could get the inspection CAM. Next is to remove the Heat shields. I feel like pulling the motor out as its driving me nuts.
Took the plastic cover off the head and also clean.
 

·
Registered
Joined
·
2 Posts
Sounds like the same issue with my STX550, oil only leaks when motor is running with a very wet bell housing.
I have used an inspection cam and 5 hours in with the mechanic and still can not find it, and it does not look to be blow by. Top of the motor looks clean but oil is from the top.
One thought was a rear main but that should not throw oil like at the top side.

The only thing I can now think of is the rocker cover gasket on the left hand side. If any one has found this issue I would be keen to know what it was.

I have pull the font of the turbo off and inspected most places I could get the inspection CAM. Next is to remove the Heat shields. I feel like pulling the motor out as its driving me nuts.
Took the plastic cover off the head and also clean.
Rear Main Engine seal STX550 2011 | The Navara Forum
 

·
Registered
Joined
·
6 Posts
Hi everybody
I am a mechanic and we come across this problem with one of the v6 diesel, oil was pissing out of the back of the motor to the bell housing there is no space to see any further than the bell housing so we thought we should send it to the specialist(nissan dealership) they diagnosed it for a Pcv hose that leaks, took six weeks to get the part from Japan , got the car back same issue, so we diagnosed it ourself and found there Is a breather housing located in the middle of the engine that was leaking on to the bell housing , I am in australia to none of the Aussie dealer got the part in stock and it’s takes ) weeks through air courier and the housing itself is roughly $150.
So to do this job Nissan said the engine has to come out, but we tried a different way to do it ,so we pulled the transmission out , which only takes 3hours and than you have just enough space to pull the turbo off , but it’s a hell of the job to do.
 
1 - 20 of 23 Posts
Top