Nissan-Navara.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So my passenger side window switch only goes down so looking at replacing it, question is can i wire it with an auto switch like my drivers so it has a toggle option?
 

·
Administrator
Joined
·
13,307 Posts
The auto up and down is in the software not the switch.

It would be a nice feature to have though.
 

·
Banned
Joined
·
1,474 Posts
So my passenger side window switch only goes down so looking at replacing it, question is can i wire it with an auto switch like my drivers so it has a toggle option?
From experience usually the only thing wrong with the switch is a dirty contact. try rocking the switch both ways for several minutes before you rite it off ,especially true if its not used regularly!
 

·
Super Moderator
Joined
·
4,599 Posts
From experience usually the only thing wrong with the switch is a dirty contact. try rocking the switch both ways for several minutes before you rite it off ,especially true if its not used regularly!
Maybe a squirt or 5 of carb/contact cleaner would be beneficial too?
Make sure its dried through before connect back up!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Damn cheers fellas, have tried the cintact clesner already didnt work unfortunately hasn't been working for a good 2 years now passenger side also goes up very slowly so ill be looking into that too
 

·
Super Moderator
Joined
·
4,599 Posts
Damn cheers fellas, have tried the cintact clesner already didnt work unfortunately hasn't been working for a good 2 years now passenger side also goes up very slowly so ill be looking into that too
The going up slowly is possibly the glass out off alinment!
as its going up put your hand on the glass and pull it backwards!
If the glass moves back slightly then goes up quicker its just a loose bolt in the mounting somewere!
My drivers glass does that! (I really need to get round to fixing it but havent had the time)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Cheers mines been doing it since i got the car 3 years ago or so just havent got around to fixing it lol
 
1 - 7 of 7 Posts
Top