Nissan-Navara.net banner
61 - 80 of 92 Posts

·
Registered
Pathfinder 2006 R51 2.5 manual
Joined
·
76 Posts
Discussion Starter · #62 ·
hey guys, apologies for my annoying persistence with this one...
With it being an extended Bank Holiday i had reasoned id try some more things and go over some previous fixes for this cars problem. i had reasoned that maybe the SCV i had fitted several months ago was incorrect as i didnt use my fuel pump number when sourcing. I decided for the sake of the cost id use the fuel pump number and purchased this Fuel Pump Regulator Valve for MITSUBISHI NISSAN 2.5 3.0 3.2 DI-D DCi Genuine | eBay
fitted it yesterday and actually the car is worse now :)
I double checked i hadnt pinched the o-ring, cleaned the pump area as best i could etc. I can prime up just fine, but when i start the car theres a little jolt not much then it idles just fine but the accelerator is so lazy i cant drive - but also now i have fault codes! i had these codes waaaay back when this first started and this is the only time they have occurred again. Codes P0089 fuel pump aka SCV i suspect and code P1272 fuel pressure relief valve which annoyingly is what i hoped to change today but i don't have quite the right tool to get in there without dismantling too much and I'm loathed to do so up to now due to lack of faith that's the issue!
So right now i am worse off than i was before swapping the SCV but at least a little further in my understanding that i think i have a fuelling issue and not a boost issue...
any ideas where to go next? I'm willing to try a new SCv via PFjones - foolishly did my research AFTER buying the ebay special and i kicked myself...
I guess my worry now is that if i do swap out the SCV again and it fixes that particular issue, i will just get back to the original problem of low power uphill :/

im not quite ready to go to the garage just yet...!
 

·
Registered
Pathfinder 2006 R51 2.5 manual
Joined
·
76 Posts
Discussion Starter · #64 ·
0089 and 1272 are classic scv faults. I'm not convinced that the one you bought is the right one
yh to be honest i think im messing up big time - ill order one from PFJones wh9ich, as it happens, is blooming cheaper than the one i just got from EBay....fingers crossed.
Can I ask....lets say i have bought the wrong one (twice), despite it fitting and the connector fitting, why would an incorrect one affect performance so dramatically?? I mean before i changed the SCV this weekend, the one i had in is Denso and same part number as the new one, but gave no error codes and performance was a little better....

this is the one i plan to get from PFJones - has my pump number listed (as did the ebay one) You are being redirected...
 

·
Registered
Pathfinder 2006 R51 2.5 manual
Joined
·
76 Posts
Discussion Starter · #65 ·
yh to be honest i think im messing up big time - ill order one from PFJones wh9ich, as it happens, is blooming cheaper than the one i just got from EBay....fingers crossed.
Can I ask....lets say i have bought the wrong one (twice), despite it fitting and the connector fitting, why would an incorrect one affect performance so dramatically?? I mean before i changed the SCV this weekend, the one i had in is Denso and same part number as the new one, but gave no error codes and performance was a little better....

this is the one i plan to get from PFJones - has my pump number listed (as did the ebay one) You are being redirected...
just to add, my fuel pump
Rectangle Wood Automotive tire Tints and shades Font

294000-530 :)
 

·
Registered
Pathfinder 2006 R51 2.5 manual
Joined
·
76 Posts
Discussion Starter · #66 ·
Ok slightly more positive update...
Today I fitted a new SCV from PFJones.
Removed fuel filter.
Replaced feed hose as cracked around the ends, replaced return hose also, refitted filter, new clips. Removed ECU side earth and cleaned, removed battery negative earth connection and cleaned. Put back together, primed and noticed a bit of a difference. Not fixed, but I can actually drive it now. got half a tank of fuel, 15 min drive and it's not fixed but better. Still feel under powered and underpowered up hill but much better than it's been. Ever so slight miss fire which isn't surprising I'll see how that goes. It's never stalled, but still no stalling either....it's a weird one but at least now I can play with it or drive to the garage to get it fixed!
I do have some smoke on booting it no surprise there and nothing too bad, I do still have a hole in the mid silencer, I have a rattle now I presume from the number 1 injector that was replaced -, ,just sounds very diesel-y sometimes on acceleration....
I'm probably back now where I was when I first got the car, so it's ok on flat or down hill, not so good uphill...!!
 

·
Registered
Pathfinder 2006 R51 2.5 manual
Joined
·
76 Posts
Discussion Starter · #69 ·
ok, hopefully ive captured relevant Data - i 100% appreciate it if you dont have time to look over these figures, but i would be hugely grateful; if you did :)

this is a long drive over various terrain - local roads, A roads, motorway, hills, flats the lot... Car drove ok, my MPG actually climbed for the first time ever peaking at 24.8mpg, couldnt see evidence of smoke on acceleration. Performance not great but certainly hugely improved. I just seem to be missing that kick especially up hill....
 

·
Registered
Joined
·
18 Posts
I don´t use Torque so I´m not sure the data is showned in the same way. But if the last column J is boostpressure you seem to be a lot on the minus side of that. And I don´t think I´ve ever seem my Navara show minus on that lowest I remeber is 0.24psi. . And also whem driving you don´t seem to have much boost at all.
 

·
Registered
Pathfinder 2006 R51 2.5 manual
Joined
·
76 Posts
Discussion Starter · #75 ·
oh nvm, just found this :)
ill do as much as i can myself, and have the garage carry out a diagnostics now i can actually drive the car to them :)
ill keep you guys updated.
 

·
Registered
Pathfinder 2006 R51 2.5 manual
Joined
·
76 Posts
Discussion Starter · #77 ·
Yes that was odd, I don't know if it was the frp or just some other random sound. Would there be any other tell tale signs ? Engine starts first time everytime, doesn't stall, sounds fine no rattles other than injector rattle in time with acceleration....
 

·
Registered
Pathfinder 2006 R51 2.5 manual
Joined
·
76 Posts
Discussion Starter · #80 ·
hey guys, i have a question about injectors, and it relates to my ongoing issue...A while ago i had a leaking oil seal via the number 1 injector (nearest bulkhead). Fixed the leak with new oil seals, but found that the injector was faulty (tested via voltmeter and via injector test kit - zero clicks form it, other injectors do click when voltage applied...) so i replaced that injector. Recently got the Pathfinder running better but now number 3 injector oil seal is leaking as is the PCV hose. So ive taken the rocker cover off and remove injectors two and three (number two i didn't remove when i replaced the o rings and copper washers due to how tight the bolt was, so this time figured i would and i got it out no problem). Injector two and three were badly carboned, and the copper washer on three is showing signs of blow by just like number 1 did when i fixed that.
I am fitting new copper washers but i wanted to test the injectors using the 12v supply plus cleaner method as shown on various you tube videos, but when i apply the cleaner and power, nothing comes out of the injector....
I may be doing it wrong, so other than sending them off, is there a good way to do a basic nozzle test with these injectors? Would a clogged injector give me the sort of issues i am experiencing (slow throttle response, lack of power/worse up hill)? I am trying to decide if i should get some refurbed injectors to rule out that potential problem, but i am seeking to understand better, if injectors could give me the sort of problems i have if they were clogged, sticky, closed/open etc etc.
Also when i did an OHM test via volt meter, they register a number which quickly drops to zero ....ive read that's not right and i should see a constant figure...any ideas?!
thanks
Clive
 
61 - 80 of 92 Posts
Top