Nissan-Navara.net banner

1 - 8 of 8 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hello
I fitted the tow bar taken from my 2017 np300 Tekna today on my newish 2019 N guard
I had the bar powder coated and it mechanically fits perfect.
The problem I am having is the electrics, my electrics kit only has one plug for the lighting connections on the tow bar loom unit so when I disconnect the lighting to plug the relay unit in there is no other plug to complete the circuits.
Did the early NP300’s have a separate lighting plug ?
I have downloaded the instructions for the NP 300 from Erich Jaeger and it shows two plugs one male one female that plugs in line with the rear lighting circuit?

Appreciate and help offered with this

Regards Neil


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
The Three plugs shown are all that is on my wiring kit one Has a blanking plug and was not used, one fits the lighting plug and the other goes to the plug located on top of the chassis with the auxiliary power I’m stuck


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,449 Posts
All I know was I was told when I changed my truck that it was not cost effective to swap the towbar as not everything fitted. It was cheaper to buy a new towbar full stop. Not sure what set up you had but have you fitted the power from the battery or do you only need lights? If you need auxiliary power you need a direct feed from your battery. Im wondering if you disconnected that on your previous truck without realising it is not fitted from the factory on the new one as its not part of the loom. Do you want single 7pin , 13 pin or old fashioned 2 socket set up? as that affects the kit you need . You can easily buy the new electrics set ups you need.
Just so you are aware the towbars have been slightly modified on new NP300s to allow for the extra two inch lift at the back causing two axle trailers not to run level.Its an issue we suffered until they supplied a new bar.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
The kit fitted on my truck was supposed to be 13 pin with aux power
The power comes from the socket on top of the chassis leg on the rear right hand corner its the connector with 8 small wires and a thick red one on a blade connector at the top of the plug.
All I want is pictures of other people’s wiring installs to asses if they have changed

Regards Neil


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,449 Posts
That is not a towbar set up i am familiar with all the lights in the Nissan kit plugs in behind the left rear light cluster! Maybe you did not remove all the wiring needed from your old vehicle as you should have taken out the loom to the battery.
The proper power kit runs power from the battery and the Kit is Nissan part no. KE5054K999
If you dont fit the proper kit the alternator wont charge properly auxiliary batteries.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
Ok i am sorted now
Any one having issues like I have please see below proper instructions for this type of Genuine Nissan Wiring Kit

Regards Neil
 

Attachments

·
Registered
Joined
·
14 Posts
My 2018/19 NP300 seems to differ from your vehicles , when I installed my Towbar the harness only had one plug , that plugged into a socket on the rear Left hand side above the Spare wheel
63998
,
here is a picture of the protective plug that I had to remove to plug in the trailer harness . Ill try to take a picture of its position ,
63996
63997
 
1 - 8 of 8 Posts
Top