Nissan-Navara.net banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all, I have owned my 2011 Thai built d40 navara for about three years now. Only after getting sick of the lumpy idle and power surging have I decided to do something about this issue now. The problem stems to the wastegate continually opening and shutting the entire time the engine is idling and when driving, but still operating as per normal under high boost. I can see on the boost gauge that the boost pressure spikes when building boost at the same rate that it flutters on idle. It keeps time of about 2 times per second. I have cleaned the solenoid and obviously found that The stem that goes to the wastegate sucks intermittently. Could this be an electrical issue? Thanks
 

·
Administrator
Joined
·
11,702 Posts
Possibly a translation issue but it isn't controlling the wastegate, that plunger actually controls the turbo variable vanes.

It is supposed to pulse at idle.

My experience is limited to spanish built models, but I assume the Thai models are the same.

Problems related to poor idle are often caused by induction air leaks
 

·
Administrator
Joined
·
11,702 Posts
Welcome to the forum by the way

if you have a few minutes please pop over to the introductory section and introduce yourself.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Possibly a translation issue but it isn't controlling the wastegate, that plunger actually controls the turbo variable vanes.

It is supposed to pulse at idle.

My experience is limited to spanish built models, but I assume the Thai models are the same.

Problems related to poor idle are often caused by induction air leaks
Hey mate cheers for the response. The Thai d40 turbo is non VNT. Meaning the actuator controls the wastegate as tradition.
Have checked all lines for leaks but I am steering as to more of an electrical issue more than anything because of the perfect time the pulse keeps
 
1 - 5 of 5 Posts
Top