Nissan-Navara.net banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi guys,
Have fitted a new switch module but both front windows not working, rear windows work fine.
Have checked fuse and ok
Picture of original blown switch attached.
50 amp Fuse did not blow despite arcing.
Maybe another fuse for front windows?
Does anyone have a wiring diagram or suggestions?
2012 d40 el frontier
LH drive model in the Philipinnes
Many thanks
received_491365735261987.jpeg
 

·
Administrator
Joined
·
15,137 Posts
This might help on fuses

 

·
Administrator
Joined
·
4,894 Posts
My manual states all windows are on the same circuit so the same fuse
Haynes up to 2010 but I'd be surprised if they'd changed the windows wiring!
 

·
Registered
Joined
·
338 Posts
Have you checked the loom between the door and the A frame they are known to break be suprised if the window relay was not the same between front and rear but you never know?
 

·
Administrator
Joined
·
4,894 Posts
No there's no relay!
If the original switch blew like that there's a serious problem somewhere! Has the new switch also blown?
Do the rear windows still work? Does the front passenger door switch work?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Door switch ,all lights,rear windows all work,just front windows not working.
Will pull out and disassemble new one,check tracks not blown again.
 

·
Registered
Joined
·
338 Posts
Yeah everything works on mine apart from the rear windows from the back but they work from the front thats why i suggested the door loom as it sounds as if you have a short if it's blown the switch
 

·
Administrator
Joined
·
4,894 Posts
Yeah everything works on mine apart from the rear windows from the back but they work from the front thats why i suggested the door loom as it sounds as if you have a short if it's blown the switch
I would think that is the child isolate button on the driver switch pack that's faulty !
 

·
Administrator
Joined
·
4,894 Posts
1 - 12 of 12 Posts
Top